Visit our online store at www.cyclesolutionsonline.com
 

2011 Road Glide Issue

I own a 2011 Harley davidson road glide custom with 103 power pack. I brought the bike to a shop for some custom work including, black powder coat everything that was chrome, hhi 7 degree rakes triple trees, painted inner fairing, grips, 23″ Russ wernimont front fender, 23″ renegade Racine wheel and matching floating rotors, shifter linkage, Arlen ness mini oval mirrors, etc…  I also purchase rinehart xtreme dual exhaust black, Roland sands turbine intake, and thundermax with auto tune setup with NGK iridium spark plugs from chris at cycle solutions. The bike ran great when I initially installed the exhaust, intake, plugs, and tmax. After the bike was ready to be picked up from the shop it started to have a slight hesitation at constant throttle. The bike actually started to get worse and drove like a motorcycle with a carburetor at a cold start in the middle of winter. The bike had about 100 miles on it. I then plugged the tmax in to my computer to check for new maps or any updates there may have been. I set a new map and ran the bike. No change what so ever. I contacted chris at this point and he asked me to call him in the am and he would go through the entire process with me of resetting the program and installing the proper map. We did that the next day. Chris had me first remove the ECM fuse for 1 minute, then installing it for 1 minute and then repeating the process a second time. Then we did the ignition process on and off 3 times for 10 seconds each cycle. Re-installed the map we found appropriate and called it a day. I then went for a ride with the bike and noticed there was no change. It was still hesitating. Chugging. I once again called Chris seeking his help to fix this bike. He asked me if I shut the bike down using the ignition or the kill switch on the right hand control. I told him I always use the kill switch. Just a habit of mine. Chris said that’s not a good idea because the tmax is a windows based program so shutting the bike down using the kill switch would be like having a bunch of programs up on your pc and just pulling the cord right out of the wall socket. So shutting the bike down using the kill switch will destroy all learned maps on the tmax. Not good. So chris had me pull the ECM fuse again. Out 1 min in 1 min twice. Then regulating the ignition on 10 seconds off 10 seconds 3 times and go for a ride. Yet again there was no improvement. So I plugged the bike back in to the computer and ran the diagnostic codes. It had a code. It was tgs1 lo. This meant I had a faulty twist grip sensor which also set an other code p2122 which was like a limp mode so nothing gets damaged. No problem. Went to Harley for them to run the code but couldn’t on their system because the thundermax wouldn’t let them. We looked the codes up in the speedo and came to the conclusion it was in fact the throttle by wire. I just bought the new part and installed it my self. The codes automatically cleared them selves. I took the bike for a ride and just like that it was running like a champ again. About 150 miles later I’m riding the bike and it starts hesitating again! I plug the tmax in again to my pc and run diagnostic codes. I find nothing there. There were also no codes in the speedo at this point. Now I’m really lost. I call Chris once again. I’m thinking it’s something wrong with the thundermax. Chris tells me he highly doubts it. But who knows at this point. So chris suggests putting the stock o2 sensors back in the pipes and removing the thundermax ECM and placing harley’s stock ECM back in the bike and running it for a while to rule out the ECM being the issue. I took it for a ride with the stock ECM and what do you know. Chris was right. It rode even worse. The bike couldn’t get out of it’s own way at this point. Now with the stock ECM I just put the bike in my trailer and dropped it off at the dealer for them to figure out what the issue was. Come to find out the issue was actually the jumper harness that plugs into the end of the twist grip sensor then to the main harness. The issue was I was initially going to have ape hangers installed so when the tech took the bike apart he snipped the green plug from the end of the jumper harness. When I decided not to do bars he just simply soldered the wires together to maintain the factory plug. Problem was he soldered it poorly and also didn’t use any shrink wrap. He used some electrical tape and of course the solder failed and one of the wires came apart. Problem solved. It was the jumper all along. The TGS was never a problem.  The tmax was installed once again with the proper map and it now runs mint. The power difference from the stock ECM and the tmax is seriously night and day. No comparison. Hopefully this will help someone out in the future If you are ever to experience this type of issue.

Cycle Solutions Inc. Presents 2011 Americade Pro Rodeo & BBQ

For the past 5 years Cycle Solutions has sponsored the Americade Pro Rodeo & BBQ at the Americade Touring Rally in Lake George, New York.  The attendence was over 5,000 this year dispite the impending weather. However, around 7:00 PM, the storm decided not to ruin our fun and the rodeo continued! The festivities concluded with door prizes from Cycle Solutions which included K&N Complete Breather Kit, K&P Oil Filter/Cooler, NGK Iridium Spark Plugs, Lucas Oil Products, & Dimple Magnetic Drain Plugs. We had fun as always and look forward to doing it again next year! YEEEHAAW!

Cycle Solutions 2011 Americade Rodeo Video